Jump to content


Photo
Noted

Performance issues at Santa Barbara

Noted

  • Please log in to reply
29 replies to this topic

#1 Bruce Hamilton

Bruce Hamilton

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 05 May 2014 - 03:13 pm

I'm getting slide show frame rates at KSBA, I have to disable everything in my control panel just to make it flyable.  :(


Intel Core i7-4790 Haswell 4.0 GHz EVGA Z97 Classified EVGA Supernova 850 G2 G.Skill Ripjaws 16GB Western Digital 1TB GeForce GTX 780 Superclock


#2 jackjda

jackjda

    Member

  • Members
  • PipPip
  • 17 posts

Posted 05 May 2014 - 04:27 pm

Me too. 6-15 fps at KSBA. By comparison, I purchased another new scenery that came out last Saturday in the state of Colorado that gets 20,40+ FPS for me with same settings.



#3 Barry Hudson

Barry Hudson

    Staff

  • Staff
  • 275 posts

Posted 05 May 2014 - 05:23 pm

Bruce, on your first look round I take it FPS were okay, can you confirm
Jackda, will be looking into it.

#4 Paul Webster

Paul Webster

    Staff

  • Staff
  • 914 posts

Posted 05 May 2014 - 05:34 pm

well i need a bit more info like: what your fsx settings are on? what scenery you using? (default, global, megascenery) what aircraft? and rough pc spec.

Its a big airport 80 odd buildings surrounded by loads of autogen housing so i wouldn't be expecting massive frame rates if you got everything maxed out.



#5 jackjda

jackjda

    Member

  • Members
  • PipPip
  • 17 posts

Posted 05 May 2014 - 05:45 pm

My settings mirror what you guys recommend. High end PC with HD devoted to FSX. I tested with ORBX walk around guy,  PADG EMB 120, neither are frame hogs. When I removed animated people FPS improved to above 10



#6 Paul Webster

Paul Webster

    Staff

  • Staff
  • 914 posts

Posted 05 May 2014 - 05:58 pm

not being rude but what one person classes as high end might be mid range to another so its easier just to say what your settings are on and then there can be no confusion. Also you didn't say what scenery your running as this can make a difference as well i.e. megascenery earth gets much better FPS due to no autogen.



#7 Bruce Hamilton

Bruce Hamilton

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 05 May 2014 - 06:16 pm

Paul, my specs are in my signature... I'm using FTX Global, following the recommended slider settings from the manual.  I've tried a couple aircraft, ranging from the default trike up to the A2A Cessna, with the same results.  With everything ticked on, I get about 9 frames average,  If I turn everything off, I get about 19.  Barry, this is my first go around... I even thought it might be a library issue, and checked out Catalina and had almost 40 frames.


Intel Core i7-4790 Haswell 4.0 GHz EVGA Z97 Classified EVGA Supernova 850 G2 G.Skill Ripjaws 16GB Western Digital 1TB GeForce GTX 780 Superclock


#8 jackjda

jackjda

    Member

  • Members
  • PipPip
  • 17 posts

Posted 05 May 2014 - 06:38 pm

I am running megascenery Earth CA 2.0, getting 20+ FPS at  FSdreamteam KLAX, i7-2600k, 3.40 GHz, 8gb ram, NVIDIA Geforce GTX 580



#9 Barry Hudson

Barry Hudson

    Staff

  • Staff
  • 275 posts

Posted 05 May 2014 - 06:51 pm

Thanks guys, will be back

#10 texerrn

texerrn

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 08 May 2014 - 03:16 am

I have KSBA installed in both FSX and P3D. I also use global, pilots mesh and vector in both.I have one of those high end computers as well. Nividia 690,i74930. When I first saw my frame rates I thought it was an error.Maybe it was installed incorrectly. Fr of 6 to 8. Not really useable. Since I discovered the cofiguration tools ans started uncheching things. Turned of all but static cars and planes. Frame rate went way up. Now see 18 in FSX. It is acceptable. In p3d it is 21 has that is what it is set at to be. Looks way better now.. One of those items, trees or hoses or clutter was bad. Now after tuning down some of the options it works well. Much better in P3D BTW. Anyway I was initially disappointed but it seems just fine now.

#11 Paul Webster

Paul Webster

    Staff

  • Staff
  • 914 posts

Posted 08 May 2014 - 07:51 am

yes im going through all the files to try and find what is causing it but it takes a while due to so many objects also i get 15-20 fps with everything on max except water on a similar spec pc to yours.

Will update when i found the bad object.


  • sebyh likes this

#12 twharrell

twharrell

    Member

  • Members
  • PipPip
  • 24 posts

Posted 09 May 2014 - 12:37 am

Paul,

How much testing did you guys do? I'm just surprised by the number of errors/performance issues that made it through beta testing. Sceneries always need patches, I know that. But these are all big things that just shouldn't get missed by a quality developer.

I also think you guys need to rethink your pricing strategy. KSBA cost me more than Flightbeam's KDEN, yet quality is night and day. If you're going to be charging those prices, your sceneries are going to have to get back to Catalina quality.

Todd

#13 Paul Webster

Paul Webster

    Staff

  • Staff
  • 914 posts

Posted 09 May 2014 - 11:05 am

Let me ask what FPS you would expect to get at an airport like Santa Barbara? with everything turned on?

also can you disable our airport and tell me what you get at the default version so i can compare to mine.



#14 Bruce Hamilton

Bruce Hamilton

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 09 May 2014 - 11:53 am

I can't speak for Todd, but I get a solid 35 or better at the default Santa Barbara. I think your version should be able to match that, it isn't a very complex scenery.

Intel Core i7-4790 Haswell 4.0 GHz EVGA Z97 Classified EVGA Supernova 850 G2 G.Skill Ripjaws 16GB Western Digital 1TB GeForce GTX 780 Superclock


#15 Christopher Low

Christopher Low

    Beta Tester

  • Members
  • PipPipPip
  • 430 posts

Posted 09 May 2014 - 01:16 pm

Bruce,

 

You can't expect it to match the framerate of a default airport. There are a lot more complex buildings, static aircraft, trees and bushes, and other items to display. Nevertheless, the team have acknowledged the comments from yourself, Todd and others, and are working hard to get things right.



#16 bruce

bruce

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 09 May 2014 - 02:23 pm

Hope this helps

Spec: i7-3770K @4GHz

8Gb RAM

Nvidia 670  2Gb

W7  64bit

 

fps       Global+ ftx mesh   cars     people    clutter     A/C

30           Y                           

 

14-15      Y                            Y           N              N             Y

13-14      Y                            Y           N              Y             Y 

9             Y                             Y           Y              Y             N

 

10           Y                            N           Y              N              Y 

10           Y                            N           Y              Y              Y

10           Y                            Y           Y              Y              Y

10           Y                            Y           Y              N              Y


Edited by bruce, 11 May 2014 - 06:31 pm.


#17 Paul Webster

Paul Webster

    Staff

  • Staff
  • 914 posts

Posted 09 May 2014 - 02:29 pm

Thanks Bruce that's great, so turning cars on drops your frames by 15! cars and people seem to be the biggest hit for you so i'll start checking them again.



#18 jackjda

jackjda

    Member

  • Members
  • PipPip
  • 17 posts

Posted 09 May 2014 - 04:28 pm

Getting 45+fps with my old freeware KSBA: http://fsfiles.org/f...tsimshotsv2/bAm



#19 Christopher Low

Christopher Low

    Beta Tester

  • Members
  • PipPipPip
  • 430 posts

Posted 09 May 2014 - 04:36 pm

Are you guys running KSBA Santa Barbara with the framerate limited? If so, try setting this to "Unlimited", and see what happens.



#20 Bruce Hamilton

Bruce Hamilton

    Advanced Member

  • Members
  • PipPipPip
  • 49 posts

Posted 09 May 2014 - 08:26 pm

I've tried both ways with the same result, Chris.  Locking the frame rate at 30 or 40 actually saves computer resources on lower end systems.  And why can't I expect to match the frame rate of a default airport?  You're replacing Microsoft's high polygon objects with custom low polygon counterparts, the frame rates should be better.  Just replacing default textures with FTX Global made a difference.


Intel Core i7-4790 Haswell 4.0 GHz EVGA Z97 Classified EVGA Supernova 850 G2 G.Skill Ripjaws 16GB Western Digital 1TB GeForce GTX 780 Superclock




Also tagged with one or more of these keywords: Noted

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users